Get a Demo

Let's Patch It!

Book a short call with one our specialists, we'll walk you through how Endor Patches work, and ask you a few questions about your environment (like your primary programming languages and repository management). We'll also send you an email right after you fill out the form, feel free to reply with any questions you have in advance!

CVE

CVE-2026-105845

Payload: SQL Injection in SQLite and Postgres
Back to all
CVE

CVE-2026-105845

Payload: SQL Injection in SQLite and Postgres

Impact

A user can submit a request that exploits a SQL Injection vulnerability in Payload.

You are affected if:

  • You use an affected Payload version.
  • Untrusted users can query readable collections using dynamic filters or joins.

You are not affected if you use MongoDB (@payloadcms/mongodb).

Patches

Users should upgrade Payload packages to >= 3.88.0 or >= 4.0.0-canary.27.

Workarounds

Upgrading to a patched version is recommended. Until you can upgrade, restrict untrusted users from supplying dynamic query filters or join parameters and limit read access to affected collections.

Package Versions Affected

Package Version
patch Availability
No items found.

Automatically patch vulnerabilities without upgrading

Fix Without Upgrading
Detect compatible fix
Apply safe remediation
Fix with a single pull request

CVSS Version

Severity
Base Score
CVSS Version
Score Vector
C
H
U
9.8
-
3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
C
H
U
0
-
3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
C
H
U
9.8
-
3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Related Resources

No items found.

References

https://github.com/payloadcms/payload/security/advisories/GHSA-v49j-62m6-pgrr, https://github.com/payloadcms/payload/commit/a742140ab4fca3160f7f83e9e7d996552ffc3b5a, https://github.com/payloadcms/payload, https://github.com/payloadcms/payload/releases/tag/v3.88.0

Severity

9.8

CVSS Score
0
10

Basic Information

Base CVSS
9.8
EPSS Probability
0.00381%
EPSS Percentile
0.32202%
Introduced Version
3.0.0,2.0.0-beta.0,4.0.0-canary.0,4.0.0-internal.011fd46
Fix Available
3.88.0,4.0.0-canary.27,4.0.0-internal.2f0d313

Fix Critical Vulnerabilities Instantly

Secure your app without upgrading.
Fix Without Upgrading